Issues:
Data not visible in CPOMS
-
You need to change your CPOMS Permissions (π’ most common)
- It may sound strange, but CPOMS kind of treats integrations like STEER like another user/staff member in your school. Just like a new member of staff, you need to grant STEER access to all the relevant student groups for the integration to work!
- Here is how:
1. Navigate to βAdminβ -> βUsersβ.
2. Use the Quick User Search on the right-hand side to find the user named βSteer
Educationβ.
3. Click on the name, then go to the βPermissionsβ tab.
4. Under Student Group Permissions, move all required student groups from the left box labelled βThis user will not be able to see students in these classesβ to the right box labeled βThis user will be able to see students in these classesβ.
5. Scroll down and click βSave detailsβ.
-
Integration Bug
- If you have already checked your permissions and think it's a bug, please alert us to the problem and we'll investigate it as quickly as possible.
- π¬ For 90% of schools who report this issue, the issue is with their CPOMS permissions. Checking this before contacting us with make the process much smoother.
Error shown when sharing data
This is usually a sign that there is something wrong with your set-up, or a bug with the integration.
Possible causes
-
Student MIS ID does not match
- Check ID in STEER and CPOMS to ensure it matches
-
Set-up data is incorrect/has been changed
- When setting up the CPOMS integration, you provided:
- API Token
- CPOMS URL
- Category ID
- Is all of this information correct?
- Has it been changed? When setting up the integration, we let you send a test incident. Assuming this was successful then, perhaps someone changed some of this data since then.
- When setting up the CPOMS integration, you provided:
-
Integration Bug
- If you think it's a bug, please alert us to the problem and we'll investigate it as quickly as possible.
Test Sharing Failed
If you are using our set-up tool, and the test incident is getting an error message, these are the likely causes:
-
You need to change your CPOMS Permissions (π’ most common)
- It may sound strange, but CPOMS kind of treats integrations like STEER like another user/staff member in your school. Just like a new member of staff, you need to grant STEER access to all the relevant student groups for the integration to work!
- Here is how:
1. Navigate to βAdminβ -> βUsersβ.
2. Use the Quick User Search on the right-hand side to find the user named βSteer
Educationβ.
3. Click on the name, then go to the βPermissionsβ tab.
4. Under Student Group Permissions, move all required student groups from the left box labelled βThis user will not be able to see students in these classesβ to the right box labeled βThis user will be able to see students in these classesβ.
5. Scroll down and click βSave detailsβ.
-
Integration Bug
- There is a known bug in CPOMS which causes permissions to sometimes be broken. This can result in sharing failing. CPOMS have acknowledged the bug and are working on a fix. In the short term, if you reach out to us, we can instruct them to manually fix your school.
-
Student MIS ID does not match
- Check ID in STEER and CPOMS to ensure it matches
-
Set-up data is incorrect
- When setting up the CPOMS integration, you provided:
- API Token
- CPOMS URL
- Category ID
- Is all of this information correct?
- When setting up the CPOMS integration, you provided:
-
Integration Bug
- If you think it's a bug, please alert us to the problem and we'll investigate it as quickly as possible.
If the sharing is not showing an error, but you can't see the test incident in CPOMS, please refer to here
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